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1. Introduction 

 

Le programme Su2ds est un plug-in Sketchup conçu pour faciliter la simulation de la lumière naturelle lors de la modélisation d’un projet architectural.  Il 

permet d’utiliser la géométrie d’un modèle créé dans Sketchup pour l’analyser dans Daysim1, avant de de réimporter les résultats numériques de cette 

simulation dans Sketchup, afin d’interpréter visuellement les résultats.  

 

 

 

 

 

Le programme Su2ds est téléchargeable gratuitement en suivant le lien suivant : http://code.google.com/p/su2ds/ 

 

Au cours de ce tutoriel, un modèle simple de bureau sera modélisé et paramétré dans Sketchup, puis exporté vers Daysim via su2ds, afin d’être analysé. Les 

résultats de cette analyse seront ensuite renvoyés vers Sketchup pour visualisation des métriques dynamiques.  

 

2. Installer le plug-in Su2ds 

 

Pour réussir cette simulation, il est nécessaire d’avoir au préalable installé Sketchup (version 7 ou supérieure), ainsi que Daysim. La version utilisée dans ce 

document est Daysim 2.1, la version Daysim 3.0 étant disponible en pre-release. Le plug-in Su2ds ne peut être utilisé que lorsque Sketchup est installé.  

 

  

                                                           
1
 Daysim est un logiciel d’analyse de la lumière naturelle qui se base sur les algorithmes de Radiance. 
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Pour installer le plug-in, vous devez suivre les étapes suivantes.  
 

 Téléchargez le dossier d’installation « su2ds ». Un dossier contenant trois fichiers s’ouvre (1) 

 Installez le plug-in wxSU, qui génère les éléments d’interface. 

 Décompressez le fichier « su2ds.zip » dans le dossier « Plugins » de Sketchup. 
 
 
 
 
 
 

 

 

 

 

En rédémarrant Sketchup, sous l’onglet « Plugins », vous avez dès lors accès à Su2ds :  

Avant de continuer, vous devez encoder votre version de Daysim dans Su2ds :  

Sketchup > Plugins > Su2ds > Preferences > Daysim version.  
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3. Modéliser un projet dans Sketchup 

3.1. Présentation du modèle étudié 

La première étape consiste à modéliser votre projet avant de paramétrer une simulation de la lumière naturelle. La géométrie retenue pour ce tutoriel est 

un modèle simple d’un local de bureau qui comprend deux ouvertures de fenêtre sur une des façades. Nous faisons également l’hypothèse que ce local se 

situe à Bruxelles, et que les fenêtres sont orientées Sud. Les figures ci-dessous indiquent les mesures principales en centimètres. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.2.   Modéliser la géométrie 

 La modélisation se fait directement sur Sketchup. Pensez à modéliser un socle autour du modèle afin de modéliser le sol, dont les dimensions doivent être 

supérieures au double de la plus grande longueur (en hauteur ou en longueur) de votre scène (voir image page suivante). Dans le cas contraire, de la 

lumière serait perdue et cela fausserait votre simulation.  

 

Plan du local Elévation de la façade avec fenêtres Coupe longitudinale 

Fenêtres 

Fenêtre 
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3.3. Appliquer des matériaux 

Ouvrez la palette des matériaux, et choisissez la bibliothèque des matériaux paramétrés pour Daysim.  

Sketchup > Window > Materials > Select > DaysimMaterialsForSketchup 

 

Vous pouvez ensuite appliquer les matériaux à votre modèle, en choisissant le vitrage « GenericDoubleGlazing72 » pour chacune des deux fenêtres.  

 

 

 

 

 

 

 

 

 

Vous pouvez compter le nombre de faces qui posent problème dans votre modèle :  

Sketchup > Pulgins > Su2ds > material > count conflicts.  

 

Sélectionnez ensuite la commande suivante :  

Sketchup > Plugins > Su3ds > materiel > resolve conflicts 

 

Voici quelles sont les modifications engendrées par cette fonction :  

 Les surfaces dont la paroi 1 a été paramétrée  

(« matériau 1 » sur la face 1) recevront  

le même « matériau 1 » pour la seconde face. 

Les deux faces de la surface ont donc finalement le même matériau.  

 Les surfaces dont les deux parois ont été paramétrées  

(« matériau 1 » sur la face 1 et « matériau 2 » sur la face 2)  

seront modifiées de sorte que la face arrière reçoive le  

même matériau que la face 1 (« matériau 1 »).  

Avant de continuer, il est conseillé de vérifier un paramètre de la géométrie de votre 

scène. Dans Radiance (qui est utilisé par Daysim au moment du calcul de simulation), une 

simple surface ne peut recevoir qu’un seul matériau, qui est assigné à la face avant et à la 

face arrière.  

Cependant, dans Sketchup, la face avant et la face arrière peuvent chacune recevoir un 

matériau différent. Afin d’éviter toute erreur vis-à-vis de ce problème, Su2ds contient une 

fonction qui permet de résoudre ces conflits de faces.  
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3.4. Définir la localisation 

Utilisez la commande  

Sketchup > Plugins > Su2ds > Set location  

Une fenêtre s’ouvre, avec les paramètres suivants :  

 Ville et pays (facultatif, ne modifie pas les calculs) 

 Latitude  

 Longitude  

 Décalage horaire 

 Altitude 

 Orientation du nord (angle) 

 Afficher la direction du nord sur la carte (oui/non) 

 

  

Si vous utilisez Daysim 2.1, vous pouvez facilement tourner 

l’entièreté de votre géométrie afin de modifier 

l’orientation du nord.  

Dans DaySim 3.0, cette opération se fait au sein même du 

logiciel de simulation.  

Il est également possible d’orienter directement le modèle 

dans Sketchup. 

 

Sur cette scène, le nord est orienté à 45° et apparait tracé 

en orange sur le plan Sketchup. Vous pouvez décider de 

l’afficher ou non.  

Ci-contre : les paramètres introduits pour 

notre simulation de bureau à Bruxelles.  

NORD 
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4. Créer une grille de points de mesures 

Daysim calcule les métriques d’éclairement naturel sur certains points spécifiques disposés sur un maillage. Pour calculer l’éclairement sur un plan, il sera 

donc au préalable nécessaire de le discrétiser, c’est-à-dire créer un ensemble de points qui caractérisent la géométrie de la surface de calcul. Pour créer un 

maillage de points avec Su2ds, vous devez d’abord définir une nouvelle couche dans Sketchup, que vous pouvez nommer « Points ».  

Une fois la couche créée, rendez-la active. Ensuite, dessinez une surface dans cette couche, qui représente le plan de travail sur lequel l’éclairement doit 

être calculé. Placez cette surface à 80cm du sol, ce qui est la hauteur habituelle pour les plans de travail de bureau.  

 

Sachez qu’il est possible de créer plusieurs surfaces de calcul, qui peuvent se trouver à différentes hauteurs, et qu’il est également possible de créer des 

surfaces de calcul comprenant des creux. 

 

Pour créer cette surface, il est plus facile de créer une section de votre modèle sur Sketchup, comme illustré ci-dessous :  

 

 

 

 

 

 

 

 

 

 

 

Pour paramétrer le maillage, utilisez la commande suivante :  

Sketchup > Plugins > Su2ds > Create sensor point mesh 

 

Une boite d’interface s’ouvre alors, vous permettant de régler deux paramètres :  

 Le choix de la couche sur laquelle vous avez placé la surface de calcul 

 L’espacement entre chaque capteur, entre chaque nœud (en mètres).  

Vous pourrez toujours changer le nombre de points sur le maillage par après, mais vous devrez recommencer le calcul de simulation.  

Vue en section 
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5. Exporter le modèle au moyen de Su2ds 

Après avoir paramétré la géométrie, les matériaux, la localisation et le maillage de votre modèle, vous pouvez entamer l’analyse sur Daysim.  

Avant d’exporter le modèle, vous devez d’abord éteindre la (ou les) couche(s) Sketchup qui ont servi à créer les maillages.  

 

 

 

 

 

 

 

 

 

 

 

 

 

Suivez la commande :  

Sketchup > Plugins > Su2ds > Export Daysim header file 
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Une boite de dialogue s’ouvre, et plusieurs champs à compléter apparaissent :  

 Project directory : emplacement du dossier qui contiendra les fichiers du projet nécessaires au calcul sous Daysim. Il est conseillé de ne pas laisser 

d’espaces dans les noms de fichiers utilisés par Daysim. 

 Project name : indique le nom du projet, et le nom du fichier « project.name.hea » qui sera créé lors de l’exportation.  

 Weather file : nécessite de joindre le chemin d’accès au fichier de données météorologiques associé au projet. Vous pouvez choisir un fichier 

« .wea » ou un fichier « .epw », qui sera directement converti pour être utilisé dans Daysim.  

 Use present location : « yes » (conserve la localisation paramétrée lors de l’étape 3.4) 

 Triangulate : « no » (cette fonction permet de créer un ensemble de triangles à partir de la géométrie crée, afin de créer un maillage d’éléments 

finis. Dans notre cas, cette application est inutile, puisque le modèle est assez simple et ne contient aucune forme complexe).  

  

Cliquez ensuite sur ok, afin d’exporter le projet, et cinq fichiers vont alors être créés : 

 Un dossier météorologique, copié depuis l’emplacement renseigné ci-avant. 

 Un dossier « Points » (.pts) qui décrit le maillage de points de calcul 

 Un dossier « Radiance » (.rad) qui décrit la géométrie et les matériaux du projet 

 Un dossier « Daysim » (.hea) qui contient la description du projet, faisant référence aux trois dossiers précédents  

 Un dossier « Log » qui contient les messages générés par Daysim pendant l’exportation.  
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6. Lancer la simulation sur Daysim 

Vous pouvez ensuite lancer Daysim afin d’y ouvrir le projet d’exportation.  

Suivez donc la commande Daysim > File > Open project  

 

Sélectionnez le dossier que vous avez créé à l’étape 5 précédemment, et le projet est chargé dans Daysim.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Une fois le modèle importé, vous pouvez vérifier les paramètres de site et du bâtiment importés à partir des onglets de la barre de tâches.   
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Vous devez ensuite paramétrer la simulation. Il est conseillé d’augmenter le paramètre « ab », nombre de rebonds diffus, et de l’établir à 5.  Pour plus 

d’informations sur le choix de ces paramètres, vous pouvez vous référer au manuel d’utilisation de Daysim, Tutorial on the Use of Daysim Simulations for 

Sustainable Design, écrit par Dr. Christoph F. Reinhart (Harvard University, 2010). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Lancez la simulation :  

Daysim > Simulation > Run simulation 
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A la fin du calcul, vous pouvez lancer l’analyse dynamique des résultats :  

Daysim > Analysis > Start Analysis 

  

Voici les résultats qui s’affichent après simulation, qui 

s’ouvrent directement dans une fenêtre Internet :  

Daysim > Analysis > View Daylighting Analysis results 
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7. Importer les résultats de Daysim dans Sketchup 

 

Lors de la simulation de Daysim, plusieurs métriques dynamiques ont été calculées. Les résultats de ces calculs sont enregistrés dans un fichier qui peut être 

importé et analysé sous forme de cartographie dans Sketchup.  

 

Dans le modèle établi dans Sketchup, suivez les commandes suivantes :  

Sketchup > Plugins > Su2ds > Import Daysim results 

 

Sélectionnez le fichier qui contient le « header file » qui a été créé au chapitre 5. 

 

A l’intérieur de ce dossier se trouve un dossier nommé « res » qui contient les fichiers de résultats générés par Daysim.  

Les fichiers en question se nomment de la façon suivante : <project name>.<daylight metric name>.DA.  

 

Pour afficher les résultats d’une métrique, sélectionnez-la et cliquez sur « Open ». Une grille colorée apparait alors dans le modèle Sketchup, représentant la 

distribution de la métrique dynamique sur la surface de points de calculs.  

 

Voici les différentes métriques évaluées et exportables depuis Daysim vers Sketchup : 

 L’autonomie dynamique continue. 

 L’autonomie dynamique maximum. 

 Le facteur lumière du jour. 

 L’éclairement naturel utile inférieur à 100lux. 

 L’éclairement naturel utile compris entre 100 et 2000lux. 

 L’éclairement naturel utile supérieur à 2000lux. 

 

Une échelle de représentation des résultats est aussi disponible, et permet de paramétrer l’affichage. Vous constaterez que cette fenêtre d’échelle disparait 

parfois lors de l’utilisation du plug-in. Vous pouvez la restaurer en utilisant la commande : 

Sketchup > Plugins > Su2ds > Show results palette 
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L’affichage des résultats peut être modifié de plusieurs manières.  

 Tout d’abord en renommant la couche des résultats, simplement nommée « results » par défaut. Donnez-lui le nom indiquant la métrique utilisée, 

et contenant une information du maillage paramétré (DA 10x5 par exemple) 

 Vous pouvez également modifier l’échelle du maillage en ajustant les bornes « min » et « max », dans le panneau « Results controls », et en cliquant 

sur « redraw ».  

 Finalement, vous avez aussi l’occasion d’afficher les valeurs calculées pour chacune métrique sur les nœuds du maillage en cliquant sur « display 

average  value ». Notez également qu’il est parfois plus facile d’évaluer les métriques dynamiques en choisissant une bonne vue en plan.  

 

Plusieurs métriques peuvent être ouvertes l’une à la suite de l’autre, et apparaitront chacune dans une nouvelle couche sur Sketchup.  
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Voici quelques illustrations de cartographie de rendus de simulation dynamique, chacune représentant une métrique :  

  

UDI 100-2000 lux (maillage 0.1m) UDI > 2000 lux (maillage 0.1m) UDI < 100 lux (maillage 0.1 m) 

Autonomie dynamique (maillage 0.5m) Autonomie dynamique continue (0.5m) Maillage seul (0.5m) 
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